Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

No network data sent from CentOS 7

Dear OCS Inventory Community,

I've compiled and installed the agent on a CentOS7 machine but it does not send the network configuration to the server.

Setting the log in debug mode, the <NETWORKS> session is empty

grep -A1 -b1 NETW ocsinventory-agent.log
547187-    </INPUTS>
547201:    <NETWORKS>
547216:    </NETWORKS>
547232-    <REPOSITORY>

Everything works fine on CentOS7 and debians, all required and recommended packages are installed (with some fix due to renaming from centos developers).

Do you have any idea on what is missing?
asked in OCS Inventory NG agent for Unix by (1.3k points)

5 Answers

0 votes

Do you mean: All information related with your devices aren't collected by OCS? SI'm concerned like you sadBut my server is Ubuntu 18.04

answered by (160 points)
0 votes
Hello curtisJB,

I've found the cause of the issue: according to the documentation, on RedHat, like distros net-tools are not required and not even recommended while they are. OCS inventory Agent should be able to collect data using "ip addr" instead of "ifconfig" but it's not. Once installed net-tools, which contains ifconfig and other stuff, it works. On ubuntu 18.04 and debian 9 the situation is the same (net-tools no longer included in default/minimal installation) but it is a recommended package. I'd suggest you to check if it's installed and, if not, try to install them.

Let me know if this apply even to your situation.

Kind regards,

Gabriele
answered by (1.3k points)
0 votes
Hi,

Which version of ocsinventory-agent have you installed?
Regards

Frank
answered by (66.4k points)
0 votes
Hi Frank,

it was 2.4.1.

Now I've installed 2.4.2 but I didn't spend time checking if it works without net-tools in different distros.

KR,

Gabriele
answered by (1.3k points)
0 votes
OK. This bug is corrected in 2.4.2.
Regards

Frank
answered by (66.4k points)
 
Powered by Question2Answer
...