Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

OCS Inventory NG server 2.5 on Ubuntu 18.04.1

I have found guide about installing 2.4 on Ubuntu 16.04, but I was looking for any latest guide on installing 2.5 on Ubuntu server 18.04.1. Ubuntu server 18.04.1 is the latest server build, and OCS 2.5 is also the latest.

I believe the installation will be almost similar, but I want to make sure that I am installing all latest components as part of OCS server requirement.

  • MySQL Server – version 4.1 or higher
  • Perl
  • Apache Web server
  • Apache Mod_perl
  • PHP with ZIP support enabled.
  • Apache Mod_php
  • Perl module XML::Simple
  • Perl module Compress::Zlib
  • Perl module DBI
  • Perl module DBD::Mysql
  • Perl module Apache::DBI
  • Perl module Net::IP
  • Perl module Archive::Zip
  • Perl module Apache2:SOAP
  • Perl module SOAP::Lite
  • Perl module XML::Entities

I found one guide in here which seems the latest

https://computingforgeeks.com/how-to-install-ocs-inventory-server-on-ubuntu-18-04/

The other one is in here http://ask.ocsinventory-ng.org/8583/tutorial-ocs-2-4-on-ubuntu-16-04

Can I use the first one and install all required components?

Thank you.

asked in OCS Inventory NG server for Unix by (160 points)

2 Answers

0 votes
Has anyone gotten this working with Server 2.5 on 18.04.1 (also MariaDB 10.3) ?  No matter what I do, the agents only check in using the 'ocs' account.  I get the following error:

OCS-NG_WINDOWS_AGENT_v2.3.1.1;database_connect;Access denied for user 'ocs'@'localhost' (using password: YES)

These files have the correct credentials and using a different database username (NOT ocs)...

/usr/share/ocsinventory-reports/ocsreports/dbconfig.inc.php

/etc/apache2/conf-available/z-ocsinventory-server.conf

/etc/apache2/conf-enabled/z-ocsinventory-server.conf

Where else would it be getting that ocs account from?  I modified the setup.sh to use a different account from ocs as well for the install.  Thanks.

Also... this is the script used to install....

https://github.com/jeremylarose/server_install_scripts/blob/master/OCSInventory2.5_Ubuntu18.04_MariaDB10.3_Install.sh
answered by (550 points)
edited by
0 votes
OK the script is now working for automated installation at ...
https://github.com/jeremylarose/server_install_scripts/blob/master/OCSInventory2.5_Ubuntu18.04_MariaDB10.3_Install.sh

needed to modify the zz-ocsinventory-restapi.conf file
answered by (550 points)
 
Powered by Question2Answer
...