Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Ocsagent 2.4.2 shows no OS version in Ubuntu 18.04

In ocsreports, All computers page, only "Ubuntu" is shown, without OS Version. The ocs agent was Installed from sources.

Lines registered in ocsinventory-agent.log:

    <HARDWARE>
      ....
      <OSNAME>Ubuntu</OSNAME>
      <OSVERSION>18.04</OSVERSION>
      ....
    </HARDWARE>

in OCS Inventory NG agent for Unix by (1k points)
edited by

4 Answers

0 votes
Hi,

Post .ocs content file.

Regards

Frank
by (70.3k points)
0 votes
<?xml version="1.0" encoding="UTF-8"?>

<REQUEST>

  <CONTENT>

    <ACCOUNTINFO>

      <KEYNAME>fields_65</KEYNAME>

      <KEYVALUE></KEYVALUE>

    </ACCOUNTINFO>

    <BIOS>

      <ASSETTAG>No Asset Tag</ASSETTAG>

      <BDATE>09/17/2015</BDATE>

      <BMANUFACTURER>Phoenix Technologies LTD</BMANUFACTURER>

      <BVERSION>6.00</BVERSION>

      <MMANUFACTURER>Intel Corporation</MMANUFACTURER>

      <MMODEL>440BX Desktop Reference Platform</MMODEL>

      <MSN>None</MSN>

      <SMANUFACTURER>VMware, Inc.</SMANUFACTURER>

      <SMODEL>VMware Virtual Platform</SMODEL>

      <SSN>VMware-42 06 b2 d4 ce 51 1c 58-cc 1e eb 04 c1 d2 84 04</SSN>

      <TYPE>Other</TYPE>

    </BIOS>

    <CONTROLLERS>

      <DRIVER>agpgart</DRIVER>

      <MANUFACTURER>Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge</MANUFACTURER>

      <NAME>Host bridge [0600]</NAME>

      <PCIID>8086:7190</PCIID>

      <PCISLOT>00:00.0</PCISLOT>

      <TYPE>rev 01</TYPE>

    </CONTROLLERS>

    <CONTROLLERS>

      <DRIVER>vmxnet3</DRIVER>

      <MANUFACTURER>VMware VMXNET3 Ethernet Controller</MANUFACTURER>

      <NAME>Ethernet controller [0200]</NAME>

      <PCIID>15ad:07b0</PCIID>

      <PCISLOT>03:00.0</PCISLOT>

      <TYPE>rev 01</TYPE>

    </CONTROLLERS>

    <CPUS>

      <CORES>1</CORES>

      <CPUARCH>x86_64</CPUARCH>

      <CURRENT_SPEED>2600</CURRENT_SPEED>

      <DATA_WIDTH>64</DATA_WIDTH>

      <L2CACHESIZE>20480</L2CACHESIZE>

      <LOGICAL_CPUS>1</LOGICAL_CPUS>

      <MANUFACTURER>Intel</MANUFACTURER>

      <SERIALNUMBER>Not Specified</SERIALNUMBER>

      <SOCKET>ZIF Socket</SOCKET>

      <SPEED>2600</SPEED>

      <TYPE>Intel(R) Xeon(R) CPU E5-2650 v2 @ 2.60GHz</TYPE>

      <VOLTAGE>3.3 V</VOLTAGE>

    </CPUS>

    <DRIVES>

      <FILESYSTEM>devtmpfs</FILESYSTEM>

      <FREE>1942</FREE>

      <TOTAL>1942</TOTAL>

      <TYPE>/dev</TYPE>

      <VOLUMN>udev</VOLUMN>

    </DRIVES>

    <DRIVES>

      <CREATEDATE>2018/8/14 08:43:33</CREATEDATE>

      <FILESYSTEM>ext4</FILESYSTEM>

      <FREE>30234</FREE>

      <SERIAL>09145d1a-9fc8-11e8-85f1-005056864326</SERIAL>

      <TOTAL>40058</TOTAL>

      <TYPE>/</TYPE>

      <VOLUMN>/dev/sda2</VOLUMN>

    </DRIVES>

    <DRIVES>

      <FILESYSTEM>squashfs</FILESYSTEM>

      <TOTAL>87</TOTAL>

      <TYPE>/snap/core/5145</TYPE>

      <VOLUMN>/dev/loop1</VOLUMN>

    </DRIVES>

    <DRIVES>

      <FILESYSTEM>nfs</FILESYSTEM>

      <FREE>1121070</FREE>

      <TOTAL>3097728</TOTAL>

      <TYPE>/mnt/discogeored</TYPE>

      <VOLUMN>172.xx.x.xxx:/root/xxxxxx/xxxx</VOLUMN>

    </DRIVES>

    <HARDWARE>

      <CHECKSUM>1572863</CHECKSUM>

      <DATELASTLOGGEDUSER>Mon Aug 27 15:33</DATELASTLOGGEDUSER>

      <DEFAULTGATEWAY>172.xx.x.x</DEFAULTGATEWAY>

      <DESCRIPTION>x86_64/00-00-13 06:06:32</DESCRIPTION>

      <DNS>127.0.0.53</DNS>

      <IPADDR>::1/1/172.xx.x.x/fe80::250:xxxx:xxxx:4326/</IPADDR>

      <LASTLOGGEDUSER>user</LASTLOGGEDUSER>

      <MEMORY>3945</MEMORY>

      <NAME>srv-ige</NAME>

      <OSCOMMENTS>#32-Ubuntu SMP Thu Jul 26 17:42:43 UTC 2018</OSCOMMENTS>

      <OSNAME>Ubuntu</OSNAME>

      <OSVERSION>18.04</OSVERSION>

      <PROCESSORN>1</PROCESSORN>

      <PROCESSORS>2600</PROCESSORS>

      <PROCESSORT>Intel(R) Xeon(R) CPU E5-2650 v2 @ 2.60GHz</PROCESSORT>

      <SWAP>3944</SWAP>

      <USERID>user1</USERID>

      <UUID>4206B2D4-CE51-1C58-CC1E-EB04C1D28404</UUID>

      <VMSYSTEM>VMware</VMSYSTEM>

      <WORKGROUP>xxx.xx.co xxxxxxxxx.local</WORKGROUP>

    </HARDWARE>

    <INPUTS>

      <DESCRIPTION>AT Translated Set 2 keyboard</DESCRIPTION>

      <TYPE>sysrq</TYPE>

    </INPUTS>

    <INPUTS>

      <DESCRIPTION>VirtualPS/2 VMware VMMouse</DESCRIPTION>

      <TYPE>Pointing</TYPE>

    </INPUTS>

    <INPUTS>

      <DESCRIPTION>VirtualPS/2 VMware VMMouse</DESCRIPTION>

      <TYPE>Pointing</TYPE>

    </INPUTS>

    <MEMORIES>

      <CAPACITY>4096</CAPACITY>

      <CAPTION>RAM slot #0</CAPTION>

      <DESCRIPTION>EDO</DESCRIPTION>

      <MANUFACTURER>Not Specified</MANUFACTURER>

      <SERIALNUMBER>Not Specified</SERIALNUMBER>

      <SPEED>Unknown</SPEED>

      <TYPE>DRAM</TYPE>

    </MEMORIES>

    <MEMORIES>

      <CAPTION>RAM slot #1</CAPTION>

      <DESCRIPTION>Unknown</DESCRIPTION>

      <MANUFACTURER>Not Specified</MANUFACTURER>

      <NUMSLOTS>1</NUMSLOTS>

      <SERIALNUMBER>Not Specified</SERIALNUMBER>

      <SPEED>Unknown</SPEED>

      <TYPE>DRAM</TYPE>

    </MEMORIES>

    <NETWORKS>

      <DESCRIPTION>ens160</DESCRIPTION>

      <DRIVER>vmxnet3</DRIVER>

      <DUPLEX>Full</DUPLEX>

      <IPADDRESS>172.xx.x.x</IPADDRESS>

      <IPGATEWAY>172.xx.x.x</IPGATEWAY>

      <IPMASK>255.255.0.0</IPMASK>

      <IPSUBNET>172.xx.0.0</IPSUBNET>

      <MACADDR>00:50:56:86:xx:xx</MACADDR>

      <MTU>1500</MTU>

      <PCISLOT>0000:03:00.0</PCISLOT>

      <SPEED>10 Gbps</SPEED>

      <STATUS>Up</STATUS>

      <TYPE>ethernet</TYPE>

    </NETWORKS>

    <PORTS>

      <CAPTION>DB-9 male</CAPTION>

      <DESCRIPTION>9 Pin Dual Inline (pin 10 cut)</DESCRIPTION>

      <NAME>J19</NAME>

      <TYPE>Serial Port 16550A Compatible</TYPE>

    </PORTS>

    <PORTS>

      <CAPTION>DB-25 female</CAPTION>

      <DESCRIPTION>25 Pin Dual Inline (pin 26 cut)</DESCRIPTION>

      <NAME>J23</NAME>

      <TYPE>Parallel Port ECP/EPP</TYPE>

    </PORTS>

    <PORTS>

      <CAPTION>Circular DIN-8 male</CAPTION>

      <DESCRIPTION>None</DESCRIPTION>

      <NAME>J11</NAME>

      <TYPE>Keyboard Port</TYPE>

    </PORTS>

    <PORTS>

      <CAPTION>Circular DIN-8 male</CAPTION>

      <DESCRIPTION>None</DESCRIPTION>

      <NAME>J12</NAME>

      <TYPE>Keyboard Port</TYPE>

    </PORTS>

    <REPOSITORY>

      <BASEURL>http://archive.ubuntu.com/ubuntu</BASEURL>

      <NAME>main</NAME>

    </REPOSITORY>

....

    <REPOSITORY>

      <BASEURL>http://archive.ubuntu.com/ubuntu</BASEURL>

      <NAME>universe</NAME>

    </REPOSITORY>

    <SLOTS>

      <DESCRIPTION>16-bit ISA</DESCRIPTION>

      <NAME>ISA Slot J8</NAME>

      <STATUS>Unknown</STATUS>

    </SLOTS>

    <SLOTS>

      <DESCRIPTION>16-bit ISA</DESCRIPTION>

      <NAME>ISA Slot J9</NAME>

      <STATUS>Unknown</STATUS>

    </SLOTS>

    <SOFTWARES>

.....

    </SOFTWARES>

    <STORAGES>

      <DISKSIZE>0.004096</DISKSIZE>

      <NAME>fd0</NAME>

      <TYPE>disk</TYPE>

    </STORAGES>

    <STORAGES>

      <DISKSIZE>91.160576</DISKSIZE>

      <NAME>loop1</NAME>

      <TYPE>loop</TYPE>

    </STORAGES>

    <STORAGES>

      <DESCRIPTION>SCSI Disk</DESCRIPTION>

      <DISKSIZE>42949.67296</DISKSIZE>

      <FIRMWARE>1.0</FIRMWARE>

      <MANUFACTURER>VMware</MANUFACTURER>

      <MODEL>Virtual disk</MODEL>

      <NAME>sda</NAME>

      <TYPE>disk</TYPE>

    </STORAGES>

    <STORAGES>

      <DESCRIPTION>DVD-RAM writer</DESCRIPTION>

      <DISKSIZE>0000</DISKSIZE>

      <FIRMWARE>00000001</FIRMWARE>

      <MANUFACTURER>VMware</MANUFACTURER>

      <MODEL>VMware Virtual IDE CDROM Drive</MODEL>

      <NAME>sr0</NAME>

      <SERIALNUMBER>10000000000000000001</SERIALNUMBER>

      <TYPE>cd</TYPE>

    </STORAGES>

    <USERS>

      <LOGIN>xxxxxxx</LOGIN>

    </USERS>

    <VIDEOS>

      <CHIPSET>VGA compatible controller</CHIPSET>

      <NAME>VMware SVGA II Adapter</NAME>

    </VIDEOS>

  </CONTENT>

  <DEVICEID>server-2018-08-15-01-19-24</DEVICEID>

  <QUERY>INVENTORY</QUERY>

</REQUEST>
by (1k points)
0 votes
Hi

The os version is correctly inventoried by the agent as you can see. This is not a problem of the agent.

To see the os version on ocsreports you have to add the column. On the page 'All computers' select in the drop list 'show/hide' OS Version value, then it will be show.

Regards

Frank
by (70.3k points)
0 votes

Hi,

I have a related question.

OCS server version :

  • PHP Version : 7.3.4
  • Web Server : Apache/2.4.38 (Debian)
  • Database Server : Debian 10 version 10.3.15-MariaDB-1
  • Version OCSReports: 2.6RC

System is :

Distributor ID: Debian
Description:    Debian GNU/Linux 10 (buster)
Release:        10
Codename:       buster

Client package version is :

ii  ocsinventory-agent                   2:2.4.2-3                     amd64        Hardware and software inventory tool (client)

With clients previous to the one packaged in Debian 10, the ocsinventory-agent seemed to report the "description" line of lsb_release, and the running kernel version in the version field.

With the new client (based on 2.4.2), it reports only Debian, and the version number.

In the line saying "Debian GNU/Linux 10 (buster)", I changed the file /usr/share/perl5/Ocsinventory/Agent/Backend/OS/Linux/Distro/LSB.pm to call "lsb_release -ds" instead of "lsb_release -is" in order to get the description.

Question is, why has this change happened ? Would it be possible to keep a similar behaviour to what was existing in older clients, so that the information displayed remains consistent?

Regards,

Stephane

by (140 points)
 
Powered by Question2Answer
...