Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Problem with agent 2.6 start

Hi 

I wonder if you could help with the error below, which has appeared recently when trying to start an agent on the multiple hosts (after first installation):

# ocsinventory-agent 

Use of uninitialized value $password in concatenation (.) or string at /usr/share/perl5/vendor_perl/Ocsinventory/Agent/Network.pm line 52.

We have been using ocsinventory software for quite a while and have been deploying it on different servers, however recently we noticed this error during the agent first startup. To be specific it affects version 2.6, as when downgraded to 2.4 it seemed to work

# rpm -qa | grep ocsinventory-agent

ocsinventory-agent-2.6.0-1.el7.ocs.x86_64

ocsinventory-agent-core-2.6.0-1.el7.ocs.x86_64

In this case it affects OS below:

# cat /etc/redhat-release 

Red Hat Enterprise Linux Server release 7.6 (Maipo)

3.10.0-957.27.2.el7.x86_64

I've seen similar posts, but didn't find any resolution. Would you  please be able to help?

Regards

Michal

in OCS Inventory NG agent for Unix by (200 points)

3 Answers

0 votes
Hi All

Am I the only one who is getting this problem? Any ideas where to look?

Michal
by (200 points)
0 votes

Hey,

I've the problem of inventory on server (see http://ask.ocsinventory-ng.org/11345/agent-does-not-sent-inventory). Where did you find the agent version 2.6? I didn't find a version newer than 2.4 (either for Windows nor for Linux).

Kind regards

by (790 points)
0 votes
Hey ocs_user

Version 2.6 is found within the OCS Inventory:

[root@server ~]# yum repolist | grep OCS

ocsinventory                OCS Inventory NG repository for Enterprise Li     15

[root@server ~]# yum --showduplicates list ocsinventory-agent

Loaded plugins: product-id, search-disabled-repos, security, subscription-manager

Installed Packages

ocsinventory-agent.x86_64                                                                                             2.4.0-1.el6.ocs                                                                                             @ocsinventory

Available Packages

ocsinventory-agent.x86_64                                                                                             2.3.0-1.el6.ocs                                                                                             ocsinventory
ocsinventory-agent.x86_64                                                                                             2.4.0-1.el6.ocs                                                                                             ocsinventory
ocsinventory-agent.x86_64                                                                                             2.6.0-1.el6.ocs                                                                                             ocsinventory
[root@server ~]#
ago by (200 points)
 
Powered by Question2Answer
...