Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

soucis avec Xampp windows

contraint d'installer sur un serveur windows !! je me heurte au problème suivant :

si j'installe xampp version 1.77 je peux installer ocs mais pas glpi.

J'installe xampp version 5.6.15 recommandé et là je veux installe ocs , dernière version 2.2 depuis le package fourni et j'obtiens ce message d'erreur " xampp installee mais pas de perl "

 

bien évidemment perl est là et ce qui est TRES TRES énervant c'est qu'il est bien dit que l'on doit pouvoir choisir cr que l'on veut installer, mais là rien a faire après ce message d'erreur plus rien je suis comme un gros .. devant le PC

Merci d'avance
in OCS Inventory NG server for Windows by (960 points)

6 Answers

0 votes
Au passage puisque c'est du PHP , pourquoi ne pourrais je pas utiliser les fichiers fournis pour linux et faire une copie toute bête dans le répetoire htdocs comme pour toute installation unix ??
by (960 points)
0 votes
question déjà posée .. mais pas de réponse satisfaisante et nouvelle version de OCS !!

http://ask.ocsinventory-ng.org/2399/ocs-2-1-2-installation-dont-work-on-xampp-5-6-8

 

6 ans et rien ne bouge sur ce sujet ??!!
by (960 points)
edited by
je viens d'essayer d'installer perl 5.10.0.. mais après un message d'erreur rien ne se passe, donc même la solution donnée n'est plus applicable ?
0 votes
ou c'est drole c'est quand j'installe wamp à la place .... puis glpi sans soucis et que pour OCS il IMPOSE d'installer xampp  !!!!
by (960 points)
0 votes
reprise à 0 !!

installation de la dernière version de OCS 2.2 avec le xampp 1.7.7

et essaie de mise à jour de PHP uniquement. Pour cela télécharger un php , copier les fichier dans un répertoire différent de php par exemple php5.6, puis modification du fichier \apache\conf\extra\httpd-xampp.conf

Pour le moment echec car le php5.6 que j'essaie d'installer n'a pas les mêmes nom de fichiers que le php fourni avec ocs (php 5.3.8) et donc apache ne se lance pas.

notamment cela : "

LoadFile "C:/xampp/php/php5ts.dll"
LoadModule php5_module "C:/xampp/php/php5apache2_2.dll"

ces fichiers n'existent pas en version 5.6 !!
by (960 points)
0 votes
C'est pas possible !!

http://wiki.ocsinventory-ng.org/index.php/Documentation:Server/fr#Sur_un_syst.C3.A8me_d.27exploitation_Windows

 

!! et effectivement ocsserveur 2.x ne veut pas s'intalller car il n'y a pas de perl, ce que confirme phpinfo !!
 

ceci ne fonctionne pas !!
by (960 points)
0 votes

(Traduction par Google)
Suivant les conseils de Berserker,  http://forum.glpi-project.org/viewtopic.php?id=132334, sur une machine avec XAMPP 5.6.15 J'utilise une autre instance d'Apache avec mod_perl seulement pour le serveur de communication OCS Inventory Server. Le lien suivant je laisse un pdf avec des instructions en espagnol.
http://danipelon.es/public/ocs_con_xampp_5.6.15.pdf

by (160 points)
 
Powered by Question2Answer
...