Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.5 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Plugin installation [closed]

Bonjour,

Sur un serveur 2.4.1.,j'ai réussi à installer les plugins côté server depuis l'interface de management des plugins.

Je précise pour ceux qui seraient confrontés au problème, que jusque là je n'arrivais pas à les installer, cela m'indiquait par exemple "ERROR: HPmgmt-master is an invalid plugin, check your sources.
Installation aborted !"

Cette erreur est due au fait que je téléchargeais sur GitHub les plugins en cliquant sur le bouton download, et récupérait un fichier du type plugin-master.zip. Il ne faut récupérer le fichier zip à ce niveau mais en passant par l'onglet releases situé sur la page de présentation du plugin.

J'arrive donc à présent à installer les plugins depuis l'interface, j'ai fais l'essai avec 3 plugins, ceux-ci sont bien présent dans la liste des plugins installés, mais j'ai un message d'erreur "Le serveur de communication a rencontré l'erreur suivante lors de l'installation :  " sans code erreur à la fin.

Screenshot

Merci de votre aide

Hello,

On a 2.4.1 server, I managed to install the server-side plugins from the plugins management interface.

I said for those who would face the problem, that until then I could not install them, it said to me for example "ERROR: HPmgmt-master is an invalid plugin, check your sources.
Installation aborted! "

This error is due to the fact that I downloaded the plugins on GitHub by clicking on the download button, and retrieved a file like plugin-master.zip. It is necessary to recover the zip file at this level but by going through the releases tab located on the presentation page of the plugin.

So I can now install the plugins from the interface, I tried with 3 plugins, they are present in the list of installed plugins, but I have an error message "The Communication server encountered the following error during installation: "No error code at the end.

SCreenshot

Thank you for your help
closed with the note: Auto answer :)
asked in OCS Inventory NG server for Unix by (570 points)
closed by

1 Answer

0 votes

Problème non résolu malgré les éléments apportés dans ce post : Plugin install 2.4

L'absence de code erreur en rapport avec le message n'est pas documenté :

Codes eereur webservice plugin engine

Edit 1 :

Après vérification dans les répertoires attendus, les fichiers Map.pm et officepack.conf ne sont pas présents lors de l'installation du plugin via l'interface. En suivant à la lettre le post indiqué, les droits, propriétaires et groupe sont correctement appliqués, le serveur apache a redémarré sans erreur, et là je n'ai plus accès au serveur OCS via le web.

Edit  2 :

J'ai donné au dossier du plugin le même nom que le fichier d'installation, soit "officepack" tout en miniscule, l'erreur venait de là ( retrouvé dans le log apache). Il fallait nommé le dossier "Officepack" avec un O majuscule, et ce, même si le nom du plugin zip est sans majuscule, tout comme le fichier de conf (officepack.conf)

answered by (570 points)
edited by
 
Powered by Question2Answer
...