Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.8 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

[OCS 2.6] - Some agent can't send Prolog [closed]

Hello,

I have some agent which can send Prolog and other agents which can't.

For example, it's an extract from /var/log/apache2/access.log:

192.168.10.92 - - [02/Mar/2020:08:26:34 +0100] "POST /ocsinventory HTTP/1.1" 200 410 "-" "OCS-NG_WINDOWS_AGENT_v2.4.0.0"
192.168.10.92 - - [02/Mar/2020:08:26:41 +0100] "POST /ocsinventory HTTP/1.1" 200 107 "-" "OCS-NG_WINDOWS_AGENT_v2.4.0.0"
192.168.10.92 - - [02/Mar/2020:08:26:43 +0100] "POST /ocsinventory HTTP/1.1" 200 410 "-" "OCS-NG_WINDOWS_AGENT_v2.4.0.0"
192.168.10.87 - - [02/Mar/2020:08:26:48 +0100] "POST /ocsinventory\" HTTP/1.1" 404 445 "-" "OCS-NG_WINDOWS_AGENT_v2.6.0.0"
192.168.10.177 - - [02/Mar/2020:08:26:49 +0100] "POST /ocsinventory\" HTTP/1.1" 404 445 "-" "OCS-NG_WINDOWS_AGENT_v2.6.0.0"
192.168.10.92 - - [02/Mar/2020:08:27:03 +0100] "POST /ocsinventory HTTP/1.1" 200 289 "-" "OCS-NG_WINDOWS_AGENT_v2.4.0.0"
192.168.10.139 - - [02/Mar/2020:08:27:16 +0100] "POST /ocsinventory\" HTTP/1.1" 404 445 "-" "OCS-NG_WINDOWS_AGENT_v2.6.0.0"
192.168.10.165 - - [02/Mar/2020:08:27:19 +0100] "POST /ocsinventory HTTP/1.1" 200 411 "-" "OCS-NG_WINDOWS_AGENT_v2.6.0.0"
192.168.10.53 - - [02/Mar/2020:08:27:19 +0100] "POST /ocsinventory\" HTTP/1.1" 404 445 "-" "OCS-NG_WINDOWS_AGENT_v2.6.0.0"
192.168.10.165 - - [02/Mar/2020:08:27:32 +0100] "POST /ocsinventory HTTP/1.1" 200 289 "-" "OCS-NG_WINDOWS_AGENT_v2.6.0.0"
192.168.10.153 - - [02/Mar/2020:08:27:46 +0100] "POST /ocsinventory\" HTTP/1.1" 404 445 "-" "OCS-NG_WINDOWS_AGENT_v2.6.0.0"
192.168.10.61 - - [02/Mar/2020:08:27:49 +0100] "POST /ocsinventory\" HTTP/1.1" 404 445 "-" "OCS-NG_WINDOWS_AGENT_v2.6.0.0"

Thanks in advance for your help.

closed with the note: Problem solved
in OCS Inventory NG agent for Windows by (270 points)
closed by

4 Answers

0 votes
 
Best answer

Franckb, finally you were right. I have in the end of my url:

server.domain.local/ocsinventory"

I have replace by server.domain.local/ocsinventory and it works

Many thanks

by (270 points)
0 votes

It comes from agent installation.

I have a GPO to deploy and upgrade agents. I do not use ocspackage because it's an upgrade.

OCS-NG-Windows-Agent-Setup.exe "/S /UPGRADE /NOSPLASH /NOW /Server=http://server.domain.local/ocsinventory"

When i make a fresh install of agent 2.6 it works.

When i make an upgrade by GPO, it doesn't work.

I have posted in OCS Inventory NG Server's forum but it would be in OCS Inventory Agent's forum.

by (270 points)
0 votes
Hi,

The url set in ocsinventory.ini is correct ?

Regards
by (79.8k points)
0 votes
Hi,

yes, the url in ocsinventory.ini is correct.
by (270 points)
 
Powered by Question2Answer
...