Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.6 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

ssl no longer working for my ubuntu agents

I noticed that the ubuntu hosts agents stopped reporting. Centos using the same SSL configuration is working.

when I run the agent I get 693 lines of:

Argument "" isn't numeric in multiplication (*) at /usr/local/share/perl/5.22.1/Ocsinventory/Agent/Backend/OS/Generic/Packaging/Deb.pm line 62.

and ending off with:

[error] Cannot establish communication : 500 Can't connect to public_hostname_for_OCS_server:443

I can see that the agent is connecting with the server but the server does not reply back to the agent installed on ubuntu. If I use HTTP the agent sends in the report without fail. I tried the 2.6.1 and 2.4.2 agents and got the same results. perl -I. Makefile.PL does not complain about any missing perl libraries when I compile the agent.

Does anyone have any ideas?

in OCS Inventory NG agent for Unix by (1.8k points)

5 Answers

0 votes

Hi,

An updated version of the agent will be published at the end of this month which corrects this problem.

Before that, you can correct the problem by removing spaces on lines 42 and 44 beginning with @infos=

Regards

Frank

by (78.6k points)
0 votes

@frankb

Are the following the issue being fixed?

This is on the latest MacOS client where it seems to make a sslv3 connection. I'm only using TLS 1.2 and 1.3 on the OCS server.

[Mon May  4 09:23:01 2020][error] Cannot establish communication : 500 Can't connect to server.example.com:443 
(LWP::Protocol::https::Socket: SSL connect attempt failed because
 of handshake problems error:14004410:SSL 
routines:CONNECT_CR_SRVR_HELLO:sslv3 alert handshake failure
by (1.8k points)
edited by
0 votes

@frankb

Hello There, by switching from Debian 8 Jessie to Debian 9 stretch (and from perl 5.20 to perl 5.24), everything still works by when the agent (v2.6.1) starts sending the inventory I am spammed endlessly (until I Ctrl-C) by the sentense :

"Argument "" isn't numeric in multiplication (*) at /usr/local/share/perl/5.22.1/Ocsinventory/Agent/Backend/OS/Generic/Packaging/Deb.pm line 62."

Removing the spaces as you mentioned indeed solved the problem, it's just to let you know. :)

ago by (290 points)
0 votes
@Ferrech

Thanks for info. This problem is corrected.

Regards

Frank
ago by (78.6k points)
0 votes

@Frank.

I incorrectly though that the connection issue is related to the error in Deb.pm. Why do some of my Debian devices have connection issues with:

[Mon May  4 09:23:01 2020][error] Cannot establish communication : 500 Can't connect to server.example.com:443 
(LWP::Protocol::https::Socket: SSL connect attempt failed because
 of handshake problems error:14004410:SSL 
routines:CONNECT_CR_SRVR_HELLO:sslv3 alert handshake failure
ago by (1.8k points)
 
Powered by Question2Answer
...