Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.8 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

OCS Plugin XML is invalid

Hi, I have installed the security plugin on my OCS server and agent but when I do an inventory it shows the following error:

WARNING *** EXECUTABLE PLUGIN => Executable plugin <C:\Program Files (x86)\OCS Inventory Agent\plugins\security.vbs> output is not UTF-8 encoded or an XML document, trying to UTF-8 encode

ERROR *** EXECUTABLE PLUGIN => Failed to UTF-8 encode executable plugin <C:\Program Files (x86)\OCS Inventory Agent\plugins\security.vbs> output

I have checked the xml created by the vbs script and can see that it isn`t a valid xml because it creates more than 1 root node.
Any ideas how to fix this. Thanks
in OCS Inventory NG plugins by (160 points)

2 Answers

0 votes
Hi, do you have and use the last version of Security plugins ?

If not, download it from ocsng github and try if it's solve your problem.

Regards.
by (5.5k points)
0 votes

Hi, yes i have the latest version of the plugin. I am using version 2.0 of the plugin, version 2.8.0.0 of the Windows agent and version 2.8.1 of OCSReports.

I followed this guide using the scripted comunication server installation:

Using extension engine - OCS Inventory Documentation (ocsinventory-ng.org)

Regards.

by (160 points)
 
Powered by Question2Answer
...