Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.9.1 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

agent 2.0.5 (linux) with ocs server 2.6

I have lot of computer with Linux (Debian/Ubuntu/Centos) with agent 2.0.5. (lot means ~3.000)

The current server is 2.4.1, and I plan to upgrade to Server 2.6.

For Windows Ocs Agent 2.0.5, it's OK. For Linux Ocs Agent 2.0.5, it's KO = not OK.

In 'activity.log' I found :

Wed Dec  8 17:49:52 2021;22407;103;plxtestjh55-2021-12-08-17-13-40;10.154.31.19;OCS-NG_unified_unix_agent_v2.0.5;prolog;new_deviceid

Wed Dec  8 17:49:52 2021;22407;100;plxtestjh55-2021-12-08-17-13-40;10.154.31.19;OCS-NG_unified_unix_agent_v2.0.5;prolog;accepted

Wed Dec  8 17:49:52 2021;22407;311;plxtestjh55-2021-12-08-17-13-40;10.154.31.19;OCS-NG_unified_unix_agent_v2.0.5;session;started

Wed Dec  8 17:49:53 2021;22407;319;plxtestjh55-2021-12-08-17-13-40;10.154.31.19;OCS-NG_unified_unix_agent_v2.0.5;session;found

Wed Dec  8 17:49:53 2021;22407;104;plxtestjh55-2021-12-08-17-13-40;10.154.31.19;OCS-NG_unified_unix_agent_v2.0.5;inventory;incoming

Wed Dec  8 17:49:58 2021;22407;320;plxtestjh55-2021-12-08-17-13-40;10.154.31.19;OCS-NG_unified_unix_agent_v2.0.5;session;end

Wed Dec  8 17:49:58 2021;22407;101;plxtestjh55-2021-12-08-17-13-40;10.154.31.19;OCS-NG_unified_unix_agent_v2.0.5;inventory;transmitted 

Even, there is here a ';session;end', the computer don't appear in the list of All_computers. (For another I don't get a ';session;end'.) (And no problem with Windows Agent 2.0.5 !)

I know this agent is very old ...

Edit/ If I change the Linux Agent to 2.4, it's Ok : the computer appear in Server 2.6 

in OCS Inventory NG agent for Unix by (3.3k points)
edited by

2 Answers

0 votes
any errors in ocsinventory-agent.log file ?
by (86.8k points)
0 votes
The problem is, for OCS Server 2.6,

for Linux hardware, with OCS agent 2.0.5, when I execute agent

- if hardware is present in the server, update is registred

- if hardware is not présent, the device is not created with inventory

and everything seems ok the log of agent (logfile=...) in this 2 cases, and also in 'activity.log' on server.

With the linux agent 2.4, it's OK, if the hardware doesn't exist, it is created.

I have a plan to update agent (to 2.4), so it's not a question very important, except for very old linux (Ubuntu 10.04 ou Debian Etch or Lenny)
by (3.3k points)
 
Powered by Question2Answer
...