Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.9.1 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Agent doesn't send any data (according to tcpdump)

Good afternoon,

I'm having an issue connecting the agent from a new server to the ocsinventory-server.

Looking at a tcpdump, no connections are being made towards the destination IP.

Just to be sure, I replaced our IP address with 8.8.8.8 - so no need to comment that the IP is wrong ;)

Doesn't matter if I use version 2.4.0 or 2.9.0-1.el8.ocs of the agent.

I've uploaded the ocsinventory-agent.log file over here;

https://file.io/FTpWgKnO34nn

Additionally, some more information in this post below, if there's anything else I can provide, just let me know.

Any suggestions or tips would be welcome.


[root@nltestprd1 ~]# /usr/local/bin/ocsinventory-agent

Jan 17 13:50:00 | /etc/multipath.conf does not exist, blacklisting all devices.

Jan 17 13:50:00 | You can run "/sbin/mpathconf --enable" to create

Jan 17 13:50:00 | /etc/multipath.conf. See man mpathconf(8) for more details

Jan 17 13:50:00 | DM multipath kernel driver not loaded


[root@nltestprd1 ~]# cat /etc/ocsinventory/ocsinventory-agent.cfg

ssl=0

local=/var/lib/ocsinventory-agent

logger=Stderr

logfile=/var/log/ocsinventory-agent/ocsinventory-agent.log

debug=1

server=https://8.8.8.8/ocsinventory

tag=OS-CUST-TAG-1

basevardir=/var/lib/ocsinventory-agent


[root@nltestprd1 ~]# cat /etc/ocsinventory/modules.conf

# this list of module will be load by the at run time

# to check its syntax do:

# #perl modules.conf

# You must have NO error. Else the content will be ignored

# This mechanism goal is to launch agent extension modules

use Ocsinventory::Agent::Modules::Download;

use Ocsinventory::Agent::Modules::Snmp;

# DO NOT REMOVE THE 1;

1;


[root@nltestprd1 ~]# cat /var/lib/ocsinventory-agent/https\:__8.8.8.8_ocsinventory/ocsinv.conf

<CONF>

  <DEVICEID>nltestprd1-2022-01-17-13-49-51</DEVICEID>

</CONF>


[root@nltestprd1 ~]# cat /var/lib/ocsinventory-agent/https\:__8.8.8.8_ocsinventory/ocsinv.adm

<?xml version="1.0" encoding="UTF-8"?>

<ADM>

</ADM>


[root@nltestprd1 ~]# curl -k https://8.8.8.8/ocsinventory

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">

<html><head>

<title>400 Bad Request</title>

</head><body>

<h1>Bad Request</h1>

<p>Your browser sent a request that this server could not understand.<br />

</p>

<hr>

<address>Apache/2.2.15 (CentOS) Server at 8.8.8.8 Port 443</address>

</body></html>

in OCS Inventory NG agent for Unix by (220 points)
retagged by

2 Answers

+1 vote
 
Best answer

Hello, 

Try removing/commenting the line:

local=/var/lib/ocsinventory-agent

It has happened to me that if that line exists, the OCS inventory ignores the server line.

Best,

by (520 points)
selected by
0 votes

Good evening johnpetrusa,

This did the trick smiley

This has cost me two days, and for some reason I never thought of that.

Thank you!  

Best regards, Patrick

by (220 points)
 
Powered by Question2Answer
...