Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.11.1 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Pas de remontée des machines sur le serveur

Bonjour à tous,

J’ai installé OCS inventory sur un serveur afin de pouvoir réaliser un inventaire du parc informatique de toutes mes machines (elles sont toutes sous Windows).

J’ai donc effectué une installation manuelle du fichier Setup sur ma machine pour tester la remontée des informations sur le serveur mais rien ne se passe.

Je suis allé dans l’observateur d’événement de Windows et j’obtiens les codes d’erreurs suivants :

- Erreur de rencontre de service <Échec du chargement/analyse du dernier état d’inventaire>.

- Erreur de rencontre de service <OCS Inventory Agent rencontre une erreur (le code de sortie est 4 => Impossible de communiquer avec le serveur de communication)>.

Lorsque je tape l’URL suivant dans un navigateur « https://<Adresse du serveur>/ocsreports », j’obtiens ceci :

Voici le fichier OCSInventory.log :

==============================================================================

Démarrage d’OCS Inventory Agent le mercredi 21 février 2024 11 :05 :22.

AGENT => Exécution de la version 2.10.1.0 de l’agent d’inventaire OCS

AGENT => Utilisation de la version 2.10.1.0 d’OCS Inventory FrameWork

AGENT => Chargement du ou des plug-ins

DLL PLUGIN => Recherche de DLL de plug-in dans le dossier <C :\Program Files (x86)\OCS Inventory Agent\plugins>

DLL PLUGIN => 0 plug-in DLL chargé avec succès sur 0 DLL trouvée

AGENT => Utilisation de la connexion réseau avec le serveur de communication

COM PROVIDER => Chargement du fournisseur de communication <C :\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>

AGENT => Utilisation du fournisseur de communication <OCS Inventory cURL Communication Provider> version <2.10.1.0>

AGENT => Envoi de Prolog

DID_CHECK => Lire l’ID de périphérique <ID_du_périphérique> et les MAC <@mac> dans le fichier <ocsinventory.dat>

COM SERVER => Initialisation de la bibliothèque cURL pour sendRequest

COM SERVER => Utilisation de cURL sans authentification du serveur

COM SERVER => Désactivation de la prise en charge du proxy cURL

COM SERVER => Activation de la prise en charge de la validation du serveur SSL cURL à l’aide de CA Bundle <C :\ProgramData\OCS Inventory NG\Agent\cacert.pem>

COM SERVER => Envoi d’une requête HTTP Post à l’URL <https://10.X.X.X/ocsinventory>

AVERTISSEMENT *** SERVEUR COM => Echec de l’envoi de la requête HTTP Post <Problème avec le certificat de l’autorité de certification SSL (chemin d’accès ? droits d’accès ?) >

COM SERVER => Nettoyage de la bibliothèque cURL

================= TRACE START ===============

================= TRACE STOP ===============

ERREUR *** AGENT => Echec de l’envoi de Prolog <Problème avec le certificat de l’autorité de certification SSL (chemin d’accès ? droits d’accès ?) >

AGENT => Fournisseur de communication de déchargement

AGENT => Déchargement de plug-in

AGENT => Durée d’exécution : 00 :00 :00.

Voici le fichier ocsinventory.ini :

[Agent d’inventaire OCS]

ComProvider=ComHTTP.dll

Débogage = 2

Local=

NoSoftware=0

HKCU=0

NoTAG=0

IpDisc=

WMI_FLAG_MODE=TERMINÉ

DEFAULT_USER_DOMAIN=

[HTTP]

serveur=https ://10.X.X.X/ocsinventory

SSL=1

CaBundle=cacert.pem

AuthRequired=0

Utilisateur=

Pwd=

ProxyType=0

Proxy=

ProxyPort=0

ProxyAuthRequired=0

ProxyUser=

ProxyPwd=

[Service d’inventaire OCS]

TTO_WAIT=120

INVENTORY_ON_STARTUP=0

Sauriez-vous m’aider sur ce sujet s’il vous plaît ? Je suis bloqué depuis 2 semaines ...

Merci beaucoup

in OCS Inventory NG agent for Windows by (260 points)
retagged by

5 Answers

0 votes
Faut-il que je créé un utilisateur avec un mot de passe pour qu'il puisse s'identifier sur la page de sécurité Windows pour utiliser le HTTPS ?
by (260 points)
0 votes
C'est de l'amateurisme ... On teste l'url de ocsreports alors que l'agent tente de poster sur ocsinventory ! Et rien sur l'install du serveur, ni sur la config d'Apache, et encore moins sur les logs d'Apache ou le log de l'inventaire ! Bref la seule chance c'est que 'ça tombe en marche'.

Installer un serveur OCS Inventory, c'est une tâche pas si simple. Le minimum est de créer un serveur (je conseille Debian et les tutos que l'on peut trouver ici) et de BIEN configurer Apache. Je préconise aussi de ne pas utiliser de certificat : c'est plus simple à déployer et configurer ...

(Bien sûr éviter d'utiliser une adresse ip pour le serveur : il faut utiliser un nom dns ! Je préconise de configurer Apache avec des virtualhost : apache2ctl et les logs d'Apache2 sont un minimum ...)
by (19.1k points)
0 votes
Bonjour,
Pour information car je ne l'ai pas indiqué, j'ai déjà un serveur (Debian 11) fonctionnel qui permet de faire tourner GLPI. Il y a, sur ce serveur, un serveur LAMP qui a été configuré avec la version de PHP 8.2. Il a été configuré pour être utilisé en HTTPS et il est possible d'accéder aux interfaces WEB soit en indiquant l'adresse IP du serveur soit par le nom de domaine.

J'ai donc repris ce serveur pour déployer l'agent OCS Inventory.
by (260 points)
0 votes
Ces dernières infos, assez utiles et assez nécessaires, auraient pu être indiquées dès le début, non ?

(Toutefois demeure le test de ocsreports et non ocsinventory ...)

Les fichiers de conf (d'Apache) fournis par OCS sont prévus pour une machine dédiée : il est donc indispensable de créer des 'virtualhost' pour associer un nom dns à OCS.

Je suggère d'ajuster le servername et les access-log (un par servername). Eventuellement en mode 443 avec le certificat : j'utilise un nom différent pour inventory et reports ...

Il faudra copier les fichiers .conf dans le fichier de virtualhost (généralement dans sites-available) puis l'activer ... (Lors d'un upgrade, il faudra penser à recommencer la copie ...)

NB : rien n'est expliqué par OCS (puisqu'il travaille dans une machine dédiée). Il faut donc être compétent Apache ... Cela s'apprend !

La seule chose utile dans le log client est 'error 500' ce qui ne semble pas le cas ici (et qui renvoie à un pb bien connu ..).

Quand vous avez une machine mutualisée qui fournit plusieurs applications, on devrait systématiquement penser à virtualhost, non ? Entre http://ip/appli/ et http://appli.local, la question est vite répondue, non ?
by (19.1k points)
edited by
0 votes
Bonjour,
Désolé pour la réponse tardive, j'ai recommencé l'installation sur une machine virtuelle vide (debian 10) et j'ai réussi à configuré correctement le serveur OCS ainsi que la remontée des machines.

Cependant, je souhaite savoir s'il est possible d'avoir de l'aide pour la liaison entre OCS et GLPI.

En effet, j'ai installé le plugin OCS inventory NG sur GLPI afin de pouvoir avoir toutes les machines du parc sur GLPI. Lors de la configuration de plugin, j'ai renseigné la base de données que j'ai créé sur le serveur OCS (les serveurs OCS et GLPI sont différents) avec le nom, l'utilisateur et le mot de passe. Lorsque je fais "Tester", cela m'affiche "Connexion à la base de données réussie" mais lorsque je vais dans l'onglet "Console OCSNG" de GLPI, rien ne s'affiche ...

Auriez vous une solution à m'apporter ?
by (260 points)
 
Powered by Question2Answer
...