Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.10.0 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Problems communication between server and client

Hello I'm new with OCS and I have it installed in Debian. I'm not very familiar with Linux too. After install sucessfully OCS I'm facing problems because clients does not communicatte with server. Is there anyone can help with steps to identify the cause of this problem? Thank you very much!
in OCS Inventory NG agent for Windows by (180 points)

2 Answers

0 votes
Hi,

Which version of ocs server and ocs agent?

Please verify /var/log/apache2/error_log file if it contains some error.

Regards

Frank
by (87.2k points)
Hi Frank,

I'm using Server 2.1 RC1 and agent 2.1.1.1.

Here error.log:

[Fri Sep 18 07:35:03.407969 2015] [mpm_prefork:notice] [pid 5614] AH00163: Apache/2.4.10 (Debian) mod_perl/2.0.9dev Perl/v5.20.2 configured -- resuming normal operations
[Fri Sep 18 07:35:03.408033 2015] [core:notice] [pid 5614] AH00094: Command line: '/usr/sbin/apache2'
[Fri Sep 18 08:51:45.273373 2015] [:error] [pid 6884] [client 193.10.10.128:41003] PHP Deprecated:  mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /usr/share/ocsreports$
[Fri Sep 18 08:51:45.275469 2015] [:error] [pid 6884] [client 193.10.10.128:41003] PHP Deprecated:  mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /usr/share/ocsreports$
[Fri Sep 18 09:20:25.996724 2015] [:error] [pid 6735] [client 193.10.10.128:42294] PHP Deprecated:  mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /usr/share/ocsreports$
[Fri Sep 18 09:37:30.749011 2015] [mpm_prefork:notice] [pid 5614] AH00169: caught SIGTERM, shutting down
[Fri Sep 18 09:37:31.969441 2015] [mpm_prefork:notice] [pid 6976] AH00163: Apache/2.4.10 (Debian) mod_perl/2.0.9dev Perl/v5.20.2 configured -- resuming normal operations
[Fri Sep 18 09:37:31.969517 2015] [core:notice] [pid 6976] AH00094: Command line: '/usr/sbin/apache2'
0 votes
Hi,

Why 2.1RC1? Latest stable version is 2.1.2 or you wanted to say 2.2RC1 perhaps.

Post ocsinventory.log agent file.

Regards

Frank
by (87.2k points)
I think it was the first version I found. Do you think it is better to reinstall everything with version 2.1.2?

Follow ocsinventory.log:

 

==============================================================================
Starting OCS Inventory NG Agent on Friday, September 18, 2015 09:38:23.
AGENT => Running OCS Inventory NG Agent Version 2.1.1.1
AGENT => Using OCS Inventory NG FrameWork Version 2.1.1.1
AGENT => Loading plug-in(s)
AGENT => Using network connection with Communication Server
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.1.1.1>
AGENT => Sending Prolog
AGENT => Prolog successfully sent
SUPPORT => No support detected, Registration key : N/A
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:00.
 
Powered by Question2Answer
...