Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.9.1 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Problème <HTTP Status Code #400> [closed]

Bonjour,

J'ai mis à jour ce jour OCS Server 2.3 sur CentOS.

J'ai testé l'installation de l'agent 2.3 sur mon poste et cela s'est déroulé sans problème.

Cependant, je rencontre un problème lors de l'envoi d'un inventaire avec le message suivant :

ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #400>

En revanche, aucun problème de remontée pour les postes ayant encore l'agent 2.1.1.3

Il y a t'il une manipulation manquante ou que j'aurais mal effectuée ?

Merci d'avance pour vos retours

Cordialement
closed with the note: Problème résolu par l'utilisateur
in OCS Inventory NG agent for Windows by (770 points)
closed by

25 Answers

0 votes
Bonjour,

Le lien vers ton serveur OCS dans ton .ini est bien en https ?
by (4.9k points)
0 votes
Bonjour vincent_n et tout d'abord merci pour ton aide.

Dans mon .ini, mon serveur n'était pas en https, j'ai fait la modification et voici désormais l'erreur que j'obtiens :

ERROR *** AGENT => Failed to send Prolog <SSL connect error>

J'ai refait la même manipulation en activant le SSL mais j'obtiens exactement le même message d'erreur

Cordialement
by (770 points)
0 votes
Ton serveur ocs est bien en https ? S'il ne l'est pas, je t'ai dis une bétise donc il faut remettre en http dans ton ini.

Est-ce que tu peux me donner tout le fichier de log de l'agent + ton fichier ini ?
by (4.9k points)
0 votes
Non mon serveur n'est pas en https, je l'ai donc remis en http comme demandé.

Voici le détail de mon fichier .ini :

[OCS Inventory Agent]
ComProvider=ComHTTP.dll
Debug=1
Local=
NoSoftware=0
HKCU=0
NoTAG=0
IpDisc=
[HTTP]
Server=http://monserveur/ocsinventory
SSL=0
CaBundle=cacert.pem
AuthRequired=0
User=
Pwd=
ProxyType=0
Proxy=
ProxyPort=0
ProxyAuthRequired=0
ProxyUser=
ProxyPwd=
[OCS Inventory Service]
PROLOG_FREQ=8
OLD_PROLOG_FREQ=8
TTO_WAIT=180
INVENTORY_ON_STARTUP=0

Et le log de l'agent :

Starting OCS Inventory NG Agent on Monday, February 20, 2017 14:58:56.
AGENT => Running OCS Inventory NG Agent Version 2.3.0.0
AGENT => Using OCS Inventory NG FrameWork Version 2.3.0.0
AGENT => Loading plug-in(s)
    DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
    DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found
AGENT => Using network connection with Communication Server
    COM PROVIDER => Loading Communication Provider <C:\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.3.0.0>
AGENT => Sending Prolog
    DID_CHECK => Read DeviceID <ET-221-2017-01-18-08-46-17> and MACs <AC:B5:7D:01:FB:3CAE:B5:7D:01:FB:3C30:10:B3:A8:52:26EC:B1:D7:96:AC:66> in file <ocsinventory.dat>
    COM SERVER => Initializing cURL library for sendRequest
    COM SERVER => Using cURL without server authentication
    COM SERVER => Disabling cURL proxy support
    COM SERVER => Enabling cURL SSL server validation support using CA Bundle <cacert.pem>
    COM SERVER => Sending HTTP Post request to URL <http://monserveur/ocsinventory>
    COM SERVER => HTTP Post response received <HTTP Status Code #400>
    COM SERVER => Cleaning cURL library
ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #400>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:00.

Encore merci pour ton aide !
by (770 points)
0 votes
Je ne vois rien d'anormal dans ton fichier ini et rien d'indicatif dans tes logs.

Vérifie les logs sur ton serveur ocs :

- /var/log/httpd/error_log

- /var/log/ocsinventory-server/activity.log (moi il est ici mais pas sûr que ce soit le cas pour tout le monde, parfois il est dans /srv/..)

Regarde si tu trouves quelque chose de bizarre, cherche l'IP/Hostname de la machine qui ne remonte pas, etc et partage moi ce que tu trouves si tu sèches je ferais de mon mieux pour t'aider
by (4.9k points)
0 votes
Et bien l'étau commence à se resserrer... Voici ce que j'ai concernant un PC qui ne remonte pas dans l'activity.log

Mon Feb 20 15:32:07 2017;12337;400;ET-221-2017-01-18-08-46-17;10.0.5.149;OCS-NG_WINDOWS_AGENT_v2.3.0.0;useragent;Bad agent or agent version too recent for server !!
Mon Feb 20 15:32:07 2017;12337;106;ET-221-2017-01-18-08-46-17;10.0.5.149;OCS-NG_WINDOWS_AGENT_v2.3.0.0;prolog;stopped by module
Mon Feb 20 15:32:07 2017;12337;515;ET-221-2017-01-18-08-46-17;10.0.5.149;OCS-NG_WINDOWS_AGENT_v2.3.0.0;end;bad_request

Si je comprends bien, le problème pourrait venir de la version de mon agent est trop récente par rapport à celle de mon serveur. Or je suis bien en 2.3 pour l'agent et le serveur.

J'ai déployé l'agent via l'utilitaire OCS Inventory NG Agent Deployment Tool de la même manière que je le faisait pour les versions précedentes.

Je regarde également de mon côté si il n'y aurait pas un paramétrage que j'aurai omis lors du déploiement
by (770 points)
0 votes

Oui tu as bien compris. Tu es certain d'avoir ton serveur en 2.3?

Si tu ne sais pas comment vérifier tu peux aller dans :

(en bas à droite)

Si tu ne vois rien, tu n'es pas en 2.3, de mémoire il y avait un problème sur les 2.1 et 2.2, on ne pouvait voir la version nul part.

by (4.9k points)
reshown by
0 votes

Je te confirme que je suis bien en 2.3.

Je viens de redéployer l'agent sur le PC sans succès. Ca marche de ton côté avec des agents en 2.3?

by (770 points)
0 votes
Oui, j'utilise le 2.3.0.0 pour mes Seven et + et le 2.1.1.1 pour mes XP et 2003.
Personnellement je le déplois par GPO avec un script, jamais utiliser le deployment tool. Tu as essayé de l'installer manuellement ?

Dans ton ini, passe le DEBUG à 2 et relance un inventaire puis partage ton fichier de log
by (4.9k points)
0 votes
Bonjour,

L'installation de la version 2.3 est le résultat d'une mise à jour d'une version précédente ou une nouvelle installation? Si c'est une MAJ as-tu bien utilisé l'option /upgrade?

Cordialement

Frank
by (86.5k points)
 
Powered by Question2Answer
...