Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.8 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

SNMP isn't working

Hi guys,

I'm using teh OCS Inventory version 2.8.0

I setted all parameters to use the SNMP scan, as defined in the documentation:

snmp_switch = on
snmp_network = 10.24.0.0 (I'd like discovery all address with 255.255.0.0 mask)

This server is my OCS HTTP server. But, when I perform the "ocsinventory-agent --debug", the process of "snmpscan" does not start:

[Fri Feb  5 14:37:19 2021][debug] Ocsinventory unified agent for UNIX, Linux and MacOSX 2.8.0
[Fri Feb  5 14:37:19 2021][debug] Log system initialised (File)
[Fri Feb  5 14:37:19 2021][debug] --scan-homedirs missing. Don't scan user directories
[Fri Feb  5 14:37:19 2021][debug] Accountinfo file: /var/lib/ocsinventory-agent/http:__10.24.X.X_ocsinventory/ocsinv.adm
[Fri Feb  5 14:37:19 2021][debug] A TAG seems to already exist in the ocsinv.adm file. The -t parameter will be ignored. Don't forget that the TAG value will be ignored by the server unless it has OCS_OPT_ACCEPT_TAG_UPDATE_FROM_CLIENT=1.
[Fri Feb  5 14:37:19 2021][debug] OCS Agent initialised
[Fri Feb  5 14:37:19 2021][debug] Turns hooks on for /etc/ocsinventory/modules.conf
[Fri Feb  5 14:37:19 2021][debug] Ocsinventory unified agent for UNIX, Linux and MacOSX 2.8.0
[Fri Feb  5 14:37:19 2021][debug] Log system initialised (File)
[Fri Feb  5 14:37:19 2021][debug] Ocsinventory unified agent for UNIX, Linux and MacOSX 2.8.0
[Fri Feb  5 14:37:19 2021][debug] Log system initialised (File)
[Fri Feb  5 14:37:19 2021][debug] Calling handlers : `start_handler'
[Fri Feb  5 14:37:19 2021][debug] [snmpscan] Calling snmp_start_handler
[Fri Feb  5 14:37:19 2021][debug]  - Net::SNMP loaded
[Fri Feb  5 14:37:19 2021][debug] [download] Calling download_start_handler
[Fri Feb  5 14:37:19 2021][debug]  - LWP loaded
[Fri Feb  5 14:37:19 2021][debug]  - LWP::Protocol::https loaded
[Fri Feb  5 14:37:19 2021][debug] Compress::Zlib is available.
[Fri Feb  5 14:37:19 2021][debug] Calling handlers : `prolog_writer'
[Fri Feb  5 14:37:19 2021][debug] sending XML
[Fri Feb  5 14:37:19 2021][debug] sending: <?xml version="1.0" encoding="UTF-8"?>

[Fri Feb  5 14:08:44 2021][debug] =END=SERVER RET======
[Fri Feb  5 14:08:44 2021][debug] Calling handlers : `end_handler'
[Fri Feb  5 14:08:44 2021][debug] [snmpscan] Calling snmp_end_handler
[Fri Feb  5 14:08:44 2021][debug] [download] Calling download_end_handler
[Fri Feb  5 14:08:44 2021][info] [download] Beginning work. I am 1214110.
[Fri Feb  5 14:08:44 2021][info] [download] No more package to download.
[Fri Feb  5 14:08:44 2021][debug] [download] End of work...

What could be happening?

Could you help me with this issue?

Thank in advance,

in SNMP by (420 points)
edited by

4 Answers

0 votes
Hi,

How was installed the agent ? manually or rpm ?

Regards

Frank
by (84.2k points)
0 votes
Hi Frank,

RPM.

Kind regards,
by (420 points)
0 votes
Hello guys,

We have news abiut this issue?

Thanks in advance,
by (420 points)
0 votes

Hello guys,

We have news about this issue?

Thanks in advance,

by (420 points)
 
Powered by Question2Answer
...