Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.8 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Package creation error


When I try to create a package bigger than 2Go my browser send me the message : "Connection reset"

I tried on different browsers, but still the same message.

I've already try to modify php.ini in /etc/php/7.3/apache2 

I've set 20 000M for the values of : upload_max_filesize and post_max_size

in OCS Inventory NG server for Unix by (320 points)

4 Answers

0 votes

Modify these values in ocsinventory-reports.conf file and restart apache.

by (83.8k points)
0 votes

I put post_max_size 4001M and upload_max_filesize 4000M

But still the same issue
by (320 points)
0 votes

hy, can you post you apache error log and perhaps check your


<IfModule mod_fcgid.c>
    MaxRequestLen         10000000
Kind regards

i really don't know the answer .. but perhaps this can help you .. he solved a similar problem

Finally solved it by adding the following line in apache :

RequestReadTimeout handshake=5 header=10 body=120


by (18.4k points)
edited by
0 votes


Here is my appache log error after trying again to upload my package and get a "connection reset": 

[Wed Apr 28 09:23:48.627446 2021] [mpm_prefork:notice] [pid 2540] AH00169: caught SIGTERM, shutting down

[Wed Apr 28 09:23:49.093817 2021] [ssl:warn] [pid 21202] AH01909: server certificate does NOT include an ID which matches the server name

[Wed Apr 28 09:23:49.630941 2021] [ssl:warn] [pid 21204] AH01909: server certificate does NOT include an ID which matches the server name

[Wed Apr 28 09:23:49.636684 2021] [mpm_prefork:notice] [pid 21204] AH00163: Apache/2.4.38 (Debian) OpenSSL/1.1.1d mod_perl/2.0.10 Perl/v5.28.1 configured -- resuming normal operations

[Wed Apr 28 09:23:49.636726 2021] [core:notice] [pid 21204] AH00094: Command line: '/usr/sbin/apache2'

[Wed Apr 28 09:24:37.490360 2021] [php7:warn] [pid 21227] [client] PHP Warning:  array_key_exists() expects parameter 2 to be array, null given in /usr/share/ocsinventory-reports/ocsreports/require/search/Search.php on $

I tried to add  :

<IfModule mod_fcgid.c>
    MaxRequestLen         10000000
In my apache2.conf file, but nothing change (apache service restarted) :/
by (320 points)
Powered by Question2Answer