Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.9.1 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Agent communication dont works [closed]

Hi,

I have some problems with communications between server and agent.

I've been used the link http://ip/ocsinventory and http://ip/ocsreports as server link. None of the links worked.

Specifications/versions:

  • Server: Ubuntu 20.04.3 LTS
  • OCS Reports: 2.9.2
  • OCS Server: 2.9.2
  • OCS Agent: 2.9.0.0

Agent log:

==============================================================================

Starting OCS Inventory Agent on Wednesday, February 09, 2022 13:44:21.

AGENT => Running OCS Inventory Agent Version 2.9.0.0

AGENT => Using OCS Inventory FrameWork Version 2.9.0.0

AGENT => Loading plug-in(s)

DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files\OCS Inventory Agent\plugins>

DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found

AGENT => Using network connection with Communication Server

COM PROVIDER => Loading Communication Provider <C:\Program Files\OCS Inventory Agent\ComHTTP.dll>

AGENT => Using Communication Provider <OCS Inventory cURL Communication Provider> Version <2.9.0.0>

AGENT => Sending getLabel request

COM SERVER => Initializing cURL library for getFile

COM SERVER => Using cURL without server authentication

COM SERVER => Disabling cURL proxy support

COM SERVER => Disabling cURL SSL server validation support

COM SERVER => Sending fileGet request to URL <http://suporte.construrohr.com.br/ocsinventory/deploy/label>

COM SERVER => fileGet response received <HTTP Status Code #404>

COM SERVER => Cleaning cURL library

AGENT => Failed to retrieve Label <HTTP Status Code #404>

AGENT => Sending Prolog

DID_CHECK => Read DeviceID <VIVO-NOTE05-2022-02-09-13-43-08> and MACs <00:FF:26:A0:B3:CB64:1C:67:BD:B7:B340:EC:99:1F:42:61> in file <ocsinventory.dat>

COM SERVER => Initializing cURL library for sendRequest

COM SERVER => Using cURL without server authentication

COM SERVER => Disabling cURL proxy support

COM SERVER => Disabling cURL SSL server validation support

COM SERVER => Sending HTTP Post request to URL <http://suporte.construrohr.com.br/ocsinventory>

COM SERVER => HTTP Post response received <HTTP Status Code #404>

COM SERVER => Cleaning cURL library

ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>

AGENT => Unloading communication provider

AGENT => Unloading plug-in(s)

AGENT => Execution duration: 00:00:00.


My ocsinventory.ini:

[OCS Inventory Agent]

ComProvider=ComHTTP.dll

Debug=1

Local=

NoSoftware=0

HKCU=0

NoTAG=0

IpDisc=

[HTTP]

Server=http://ip/ocsinventory

SSL=0

CaBundle=cacert.pem

AuthRequired=0

User=

Pwd=

ProxyType=0

Proxy=

ProxyPort=0

ProxyAuthRequired=0

ProxyUser=

ProxyPwd=

[OCS Inventory Service]

TTO_WAIT=60

INVENTORY_ON_STARTUP=0

PROLOG_FREQ=10

OLD_PROLOG_FREQ=10


Can anyone help me with that communication issue?

closed with the note: Installed another version. it works.
in OCS Inventory NG server for Unix by (200 points)
closed by

4 Answers

0 votes
HTTP Status Code 404 ?

Are you sure that Apache is OK ?

It's a good help to have a basic knowledge in Apache settings.

Consider for troubleshooting : 'apache2ctl -t' and 'apache2ctl -S'. Also look at log files /var/log/apache2/access;log and error.log

Also read my reply to "How to change default server URL"
by (8.4k points)
edited by
0 votes
Yes, Apache is OK! OCS REPORTS is accessible and GLPI that's in the same server is accessible too.

Another errors thats been occured are HTTP 200, HTTP 500 and it never works.
by (200 points)
0 votes
Hi,

Errors in apache error log file ?
by (87.2k points)
0 votes
Hi,

No errors in apache logs.
by (200 points)
 
Powered by Question2Answer
...