Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.11.1 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

main page OK but all computer/software tab empty [closed]

Hi,

Since 2.12.1 my "all computer" and "all software" pages are empty but the main page shows up how many devices and what os they running.

I didn't upgrade OCS i did a fresh install following the official guide: https://wiki.ocsinventory-ng.org/03.Basic-documentation/Setting-up-a-OCS-Inventory-Server/

the server is running on RockyLinux 8 and SELinux is disable. 

I've try checking the database for missing table or column like other posts have mentioned but all is good on this side.

I've also checked computers and softawres related tables and all the data is there so i'm a bit confuse.

Did someone know how to fix this issue ?

This is what i see:

closed with the note: solved
in OCS Inventory NG server for Unix by (200 points)
closed by

3 Answers

0 votes
Start search on this site : every 2 weeks this question is asked ... it's really boring !

EDIT (after close):

The link for installation from Wiki is OUTDATED (as you could read : Debian 9, Centos 7 !). You have to follow more recent and complete tutorials (especially for Redhat family distribution) ...

Starting from 2.8, It's mandatory to have cron tasks for computing count of softwares !

Many users don't follow instructions about these cron tasks, and this is the usual reason for 'software empty'.

I'm quite surprise by PHP 8 requirement for 2.12.1. (Also definitively I prefer Debian family distributions : it's more easy to have a correct installation with all relative components)
by (17.9k points)
edited by
0 votes
Well I've searched and tried all of the solution that I could found here ... or maybe I missed one I'll check again
by (200 points)
0 votes

Okay so for those who have the same problem, I found that the server need php 8.0 or higher  at least for version 2.12.1 because I had installed php 7.X as it is written "PHP 7 or Higher" in the wiki ...

by (200 points)
 
Powered by Question2Answer
...