Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.11.1 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

permission error

I have installed OCS Inventory on Fedora 20. Then I try http://xx.xx.xx.xx/ocsreports but get an error:

"You don't have permission to access /ocsreports/install.php on this server"

In error_log I can see following:

suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)

[auth_digest:notice] [pid 2675] AH01757: generating secret for digest authentication ...

[lbmethod_heartbeat:notice] [pid 2675] AH02282: No slotmem from mod_heartmonitor

[mpm_prefork:notice] [pid 2675] AH00163: Apache/2.4.10 (Fedora) OpenSSL/1.0.1e-fips mod_nss/2.4.6 NSS/3.15.2 Basic ECC PHP/5.5.16 mod_perl/2.0.9-dev Perl/v5.18.1 configured -- resuming normal operations

[core:notice] [pid 2675] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'

[authz_core:error] [pid 2680] [client xx.xx.xx.xx:4321] AH01630: client denied by server configuration: /usr/share/ocsinventory-reports/ocsreports/install.php

What can I do to solve this problem?


in OCS Inventory NG server for Unix by (140 points)

1 Answer

0 votes
How do you have install your OCS ?

If you have install it by the tar.gz : selinux is the problem

if you have install from the rpm : use the repository from remi collet and install the latest version.
by (22k points)

I have installed it by the tar.gz but then I disabled selinux


SELinux status: disabled

and restart services httpd and mysqld

but all the same I get mistake 403 Forbidden

You don't have permission to access /ocsreports on this server.

Also I moved all the content from /ocsreports to /var/www/html and site has worked. But it is not a problem solving as I think.
OK you must never move the content of ocsreports like that.

I think you don't know wich parameters to put in a fedora for apache when you launch the setup.sh. The best way is to errase what you have done and install the rpm from remi collet repository.



"I think you don't know wich parameters to put in a fedora for apache when you launch the setup.sh" - it was not a problem. I have found a reason of mistake. It is: write "Require all granted" instead of "Allow from all" in config files. I did it and OCS worked. Thank you for help

Powered by Question2Answer