Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.9.1 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

which version do you have?

I Run PHP 5.6.30-5+deb.sury.org~precise+2 on Ubuntu 12.04 but when i go to http://ocsinventory-ng/ocsreports/install.php I get the following message

Your PHP installation is older than version 5.4 and will not be compatible with incoming versions (version :  5.3.10-1ubuntu3.26 )

Thank you in advance

related to an answer for: Crash after 2.3 update
in OCS Inventory NG server for Unix by (340 points)

5 Answers

0 votes

Hello,

create file e.g. "info.php" and insert following lines:

<?php
echo phpversion();
phpinfo();
?>

Put this file to the same folder where install.php is located.

Point your browser to http://ocsinventory-ng/ocsreports/info.php and check result.

Do you see version 5.6.30?

OCS uses the same function (phpversion();) for PHP version detection.

by (1.5k points)
0 votes

Hi,

it shows the same version 5.3.10

Kind regards,

by (340 points)
0 votes
So your webserver is configured to use PHP v 5.3.10
by (1.5k points)
0 votes
And i can i change this?
by (340 points)
0 votes

Run this command in console:

php -v

Output should be like this:

root@spaceship:/# php -v
PHP 5.6.30 (cli) (built: Feb  8 2017 21:24:25)
...

by (1.5k points)
 
Powered by Question2Answer
...