Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.10.0 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

OCS Linux And Windows agents can't communicate with the OCS Server [closed]

Environment:

OCS Server: Ubuntu 14, OCS - 2.3.1

OCS Agents: OCS 2.3 on Ubuntu 14, Windows 7, Windows 8, Windows 10

I don't see any servers or computers at the http://website/ocsreports/

I checked my  Agent log file and I got this:

 [error] Cannot establish communication : 404 Not Found

 mod_perl module correctly installed on the OCS server.

My Ubuntu agent config file is :

server=http://server.ip.address/ocsinventory
debug=1
basevardir=/var/lib/ocsinventory-agent

I restarted Apache web server few times, it wasn't help me.

What else can I do to fix this issue? 

Please help me ASAP.

THANKS!

closed with the note: Problem closed - no more discussion on the topic
in OCS Inventory NG agent for Unix by (440 points)
closed by

15 Answers

0 votes

You said: You can follow this procedure (ubuntu 16.04). I think it will work for Ubuntu 14.04.

But which procedure? 

Please specify. 

by (440 points)
0 votes
I've updated my answer.

Regards

Frank
by (87.4k points)
0 votes

 frankb  GLPI - this is another inventory software. So I didn't install it.

You asked: Did you enable z-ocsinventory-server.conf file with a2enconf command?

Yes I did. But I still have the same issue.

What else can I do to resolve it ?

by (440 points)
edited by
0 votes

[Wed Apr 12 14:57:50.316424 2017] [ssl:warn] [pid 20268] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Apr 12 14:57:50.316460 2017] [ssl:warn] [pid 20268] AH01909: RSA certificate configured for mywebsite:443 does NOT include an ID which matches the server name

You told me that your site is in http but I don't understand why it says that the server name in the certificate is not correct. If you have a certificate, it means you are in https... Are you sure you are not ?

Try in your agent conf file

server=https://yourserver/ocsinventory

by (4.9k points)
0 votes
If I use https on the ocs agent config file I get this:

[error] Cannot establish communication : 500 SSL_ca_file /var/lib/ocsinventory-agent//https:website/ocsinventory/cacert.pem does not exist

This is my OCS agent config file

server=http://mywebserver/ocsinventory
basevardir=/var/lib/ocsinventory-agent/
logfile=/var/log/ocsinventory-agent.log
tag=ocs-server
debug=2
ssl=0

SNMP_SWITCH = ON
by (440 points)
edited by
 
Powered by Question2Answer
...