Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.9.1 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Plugins OCS Release 2.3

Bonjour,

Je pense que le problème à déjà été posé, mais j'ai regardé les solutions et les remarques, et je n'ai trouvé aucune solution..

Mon serveur OCS est sous Debian 7.11,  PHP5,  Apache2.

J'ai téléchargé, certains plugins (listprinters.zip, networkshare.zip, officepack.zip, security.zip, uptime.zip)

Je les ai bien déposé dans la dossier "Download" du serveur, et les ai installé via la console Web du serveur, et tout s'est bien déroulé..

J'ai aussi copier dans le dossier "Plugin" du répertoire  Agent, les .vbs contenu dans les .zip dst Plugins, sur le PC, l'agent est installé et a remonté l'inventaire... Mais, pas les infos des plugins...

Je pense avoir raté une configuration, mais je ne sais pas ou...

Si quelqu'un pouvais m'aider à comprendre le pourquoi du comment...

Merci d'avance,

Cordialement..

Epoc

in OCS Inventory NG server for Unix by (950 points)

17 Answers

0 votes

Bonjour Epoc,

Déjà, quelle version d'OCS sur le serveur ?

Oui, j'avais eu moi aussi un peu de "casse" sur mon serveur OCS après une réinstallation de plugins et il m'a fallut aussi copier les fichiers nom_plugin.conf et Map.pm manuellement.

Bizarre tes doublons... Peut-être un fichier comme /usr/share/ocsinventory-reports/ocsreports/config/computer/plugins.xml qui a été mal "nettoyé" pendant la désinstallation de l'un des plugins > Tu peux vérifier si tu n'as pas de plugin en double dans ce fichier.

Donc, bonne remontée des plugins avec l'agent 2.1.1 (donc PC sous XP ?!) et pas de remontée avec l'agent 2.3.0 (donc PC sous W7 ou W10 ?)... Est-ce bien cela ?

Que les infos remontent correctement dans le serveur avec l'agent 2.1.1 écarte un soucis au niveau de la partie serveur... Restent donc selon moi les stations.

Tu m'écrivais que tu avais fait un test avec une VM (sous XP et l'agent 2.1.1 ?) et as-tu aussi essayé une VM sous W7 avec l'agent 2.3.0 ?

Tes VM sont-elles fraichement installées sans modification notable (par ex. pare-feu, UAC, connexion à un AD, GPO, moteur de script changé par défaut ?) > D'ailleurs, parc en workgroup ou domaine ?

As-tu bien supprimé les anciennes versions des VBS dans le dossier Plugins des agents (il ne faudrait pas qu'il essayent de remonter les infos à la place des nouveaux).

> Pour tes agents en v. 2.3.0, tu peux aussi faire des leurres en VBS pour vérifier la remontée correcte d'infos de plugins dans l'inventaire et / ou dans le fichier local en XML.. Par exemple pour le plugin uptime, tu créé un vbs, tu lui met le contenu suivant, tu le copies dans le dossier plugin et tu enlèves temporairement le vbs d'origine pour essayer :

On Error Resume Next

Wscript.echo _
 "<UPTIME>" & VbCrLf &_
 "<TIME>LEURRE_UPTIME</TIME>" & VbCrLf &_
 "</UPTIME>"


Voilà quelques pistes...

by (28.1k points)
edited by
0 votes

Bonjour Stéphane,

Alors, pour ce qui est des infos du serveur: ça va "il tiens la route".. :-)

J'ai fais deux tests sur deux machines d'OS différent..

En Win XP, avec l'agent 2.1.1, tout remonte nickel..

En Win 7 32, avec l'agent  2.1.1 tout remonte nickel (Uptime, Clé Office, Security, etc...)

J'ai placé des .vbs dans deux PC en Win7 32 & 64, je verrai demain, car je n'avais pas la main sur les PC pour forcé l'inventaire (PC OQP par les user)..

Mais le serveur répond bien...je n'ai pas trop bidouiller dedans, juste les fichiers et dossiers pour les quelques plugins qui ont remonté les erreurs en fin d'installation sur la console Web du serveur...

Perso deux plugins me seront fort intéressant: le UPTIME, et le SECURTY, le OFFICE Pack serait un plus..

En ce moment nous faisons la chasse aux PC qui restent UP durant des semaines, et ceux des "Grands Grecs" qui installent n'importe quoi comme sécurité...

by (950 points)
edited by
0 votes

Bonjour Epoc,

Ok pour tes précisions... L'agent client v. 2.3.0.0 serait tout de même mieux pour les PC récents ! frown

Pour ce qui est des plugins qui t'intéressent, sur l'ensemble de mon parc :

UPTIME et OFFICEPACK fonctionnement parfaitement sur les OS XP à W10 et W2k8 à W2k16.

SECURITY fonctionne sur XP à W10 mais pas (à ce jour) sur les OS de la branche serveurs.

by (28.1k points)
0 votes

Bonjour Stéphane,

Alors les news pour ce matin : bonnes nouvelles sur les PC de test (.vbs & plugins), les infos sont remontées..

Après constat, je pense que les PC doivent être redémarrés, et non forcer l'inventaire...sur 5 PC tests, 4 sont positifs aux infos plugin, et 1 négatif, (qui n'a pas été arrêté et qui n'a pas été pas redémarré...)

Je porterais plus d'attention en poussant le test sur un plus grand nombre de machines durant cette journée..

Les OS & Agents: Win XP (Agent 2.1.1), Win 7 32 & 64 (Agent 2.3.0)...

Aujourd'hui j'élargirai mon test sur certaines machines en Win10..

Cordialement, 

Epoc,

by (950 points)
0 votes
Bonne nouvelle !

A+, Stéphane
by (28.1k points)
0 votes
Bonjour Stéphane,

Ben RAS, et je pense clôturer le post, tout est fonctionnel, les infos des plugins sur les différents OS remontent correctement, même en Win10 64...!

Un grand merci à toi pour toutes les infos et et le soutient...

Cordialement

Epoc..
by (950 points)
0 votes
Bonjour Epoc,

ce fut un plaisir !

Comme disait JCB, "La connaissance s'accroît quand on la partage !"

A+,

Cordialement, Stéphane
by (28.1k points)
 
Powered by Question2Answer
...