Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.8 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

Installer OCS Inventory sur une installation Apache 2.4.10 (sans XAMPP)

Bonjour,

Nous utilisons actuellement une infrastructure "Windows Server 2008 R2" 64bits avec les produit suivants installés dessus:

- Apache 2.4.10
- PHP 5.5.19
- MySQL 5.6
- ActivePerl  ou StrawberryPerl (Pas encore installé)

Nous aimerions installer OCS Inventory sur cette infrastructure.
Nous avons trouvé ce guide qui indique la procédure à suivre : http://wiki.ocsinventory-ng.org/index.php/Howtos:Install_OCS_on_WAMP#Installation_of_OCS_Inventory_NG_Server_on_Windows.2C_without_using_OCS_packaged_version

Seulement le guide n'est pas actualisé pour Apache 2.4.10.
Car le fichier mod_perl-2.0.ppd n'est plus disponible en ligne. De plus le module mod_perl n'est pas compatible avec Apache 2.4.

Avez-vous une solution pour utiliser OCS Inventory Server 2.1.2 sans le module mod_perl ? (Avec un fonctionnement de perl par CGI par exemple ?)

Dans l'attente de votre aide,

Barbuslex
in OCS Inventory NG server for Windows by (130 points)

1 Answer

+1 vote
perl et mod_perl ne sont pas le même language exactement. OCS Inventory NG est intimement lié à mod_perl et il n'est pas possible de s'en passer.

De plus mod_perl est compatible avec apache 2.4 mais sous linux uniquement. OCS Inventory NG étant fait pour tourner sous linux, puis porté sous windows, ce genre de problème de dépendance est donc secondaire. D'ailleurs nous ne recommandons pas d'utiliser windows pour des parc de plus de 1000 postes inventoriés.

Sinon dans le futur il est prévu de réécrire le moteur d'OCS pour se débarrasser de mod_perl et passer surement sur quelque chose comme du fcgi.
by (21.7k points)
Malheureusement oui, mod_perl n'a plus l'air très maintenu au vu des liens nécéssaire à son installation qui sont 404.
De plus, XAMPP s'est déjà séparé de mod_perl dans la dernière version présente en ligne.
Savez-vous si la release de OCS Inventory Server en fcgi sortira dans un futur proche ?
La refonte en fcgi est un gros travail et il fait partie des gros chantier avec la refonte de la base de données sur lesquel on planche depuis un moment encore à l'état de projet ...

Pour le moment je doute que ce soit en 2015 que l'on voit ce changement (on fait de notre mieux pendant notre temps libre).

En attendant le mieux est d'installer OCS sur un linux (sur une VM ça marche très bien). En plus les performances seront meilleure et puis pourquoi payer une licence windows pour installer que des logiciels libres ?
A ok merci pour tout ces renseignements utiles.

En fait oui c'est ce que j'ai fait. J'ai installé OCS sur un CentOS 7 et les performances n'ont rien avoir.

En fait j'avais mutualisé l'installation de notre infrastructure web intranet avec OCS pour éviter de faire 2 serveur pour des modules web. L'utilité de windows pour nos serveurs est notament la rapidité de l'authentification NTLM sur nos pages intranet, sur ce point il faut le dire Microsoft a de meilleures performances ^^
 
Powered by Question2Answer
...