Welcome to OCS Inventory NG community support, where you can ask questions and receive answers from other members of the community.

Please ask questions only in English or French.

Release 2.10.0 available

The official documentation can be found on http://wiki.ocsinventory-ng.org. Read it before asking your question.

why my login page is so slow ?

Ok,
I did all I can.  At least, I think so.  I did lot of searches, lot of tests, but can't find the problem....

I have an OCSNG server installed on an Ubuntu VM [Ubuntu Linux 18.04.6], under an Apache2 web server.  My auth-mode is «local».

the issue is, when I submit a login/password combinaison, it stuck for 15-20 minutes (!) before the loading of the dashboard.

I first cleaned the software table, which had ±5M records....no gain

I change my auth-mode to «always ok» and then I get into the dashboard in seconds.

I found the stuck appeared just after the click on the submit button by use of js alert here and there in the pages........

I looked and looked to the code, and the queries and everything looks fine......

any idea ?

in OCS Inventory NG server for Unix by (310 points)

2 Answers

0 votes
Hi,

Have you errors in apache error log file ?
by (87.4k points)
0 votes
here's what is still present in the log :

ocsinventory-server: Bad setting. `IPDISCOVER_LINK_TAG_NETWORK` is not set. Default: `0`

[Mon Mar 28 00:06:00.622003 2022] [ssl:warn] [pid 28766] AH01909: 127.0.0.1:443:0 server certificate does NOT include an ID which matches the server name

[Mon Mar 28 00:06:00.622702 2022] [mpm_prefork:notice] [pid 28766] AH00163: Apache/2.4.29 (Ubuntu) OpenSSL/1.1.1 mod_perl/2.0.10 Perl/v5.26.1 configured -- resuming normal operations

[Mon Mar 28 00:06:00.622725 2022] [core:notice] [pid 28766] AH00094: Command line: '/usr/sbin/apache2'

[Mon Mar 28 08:25:30.572542 2022] [perl:error] [pid 20043] [client xxx.xxx.xxx.xxx] Apache2::RequestIO::read: (70007) The timeout specified has expired at /usr/local/share/perl/5.26.1/Apache/Ocsinventory.pm line 164

:-/ I modify the ServerName in the cont file and in the db.inc file to indicate 127.0.0.1 instead of localhost, but no gain :-/ ...
by (310 points)
edited by
 
Powered by Question2Answer
...